Routine Maintenance
Incident Report for Quartzy
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 21:11 PST
Investigating
We are undergoing routine maintenance - some features will not work as intended.
Posted Nov 18, 2020 - 21:00 PST
This incident affected: Quartzy Web Application.